Autonomous AI agent finds four severe vulnerabilities in EPICS industrial control software in under four hours
An autonomous AI security agent named Cipher discovered four previously unknown vulnerabilities in EPICS Base, including a critical CVSS 9.8 integer overflow allowing remote code execution, in 3 hours and 49 minutes with minimal human intervention.
Summary
An autonomous AI agent called Cipher, developed by Causal Security, independently discovered four severe security vulnerabilities in EPICS (Experimental Physics and Industrial Control System) Base, the open-source toolkit used to control particle accelerators, fusion reactors, and other major scientific infrastructure. The flaws include a critical integer overflow (CVE-2026-114595, CVSS 9.8) enabling remote code execution, two high-severity memory safety issues (CVE-2026-114596 and CVE-2026-114597), and a type confusion bug (CVE-2026-114598), all affecting EPICS Base versions prior to 7.0.11.
The discovery required no human intervention for initial investigation, followed by a single authorization for deeper exploitability testing in a secure environment. EPICS, originally developed by Los Alamos and Argonne National Laboratories, powers approximately 90 major scientific and industrial facilities worldwide, including the ITER fusion reactor and Argonne's Advanced Photon Source. CISA has issued an advisory warning that successful exploitation could lead to denial of service, memory corruption, information disclosure, or arbitrary code execution on systems directly controlling physical equipment.
Vulnerability breakdown and AI-driven discovery
- CVE-2026-114595 (Critical, CVSS 9.8): An integer overflow vulnerability leading to attacker-controlled out-of-bounds heap write with potential for remote code execution on EPICS controller systems.
- CVE-2026-114596 (High, CVSS 8.2): Improper message-length validation causing out-of-bounds memory writes and controller-process crashes through malformed network input.
- CVE-2026-114597 (High, CVSS 7.5): Insufficient bounds checking enabling out-of-bounds memory reads and process termination.
- CVE-2026-114598 (High, CVSS 7.5): Type confusion flaw permitting denial of service and potential exposure of adjacent memory contents.
- AI agent methodology: Cipher performed autonomous investigation of the unfamiliar EPICS codebase, then validated four working exploits in under four hours with only one human instruction authorizing deeper testing.
Why it matters
This discovery signals a fundamental shift in vulnerability research for open-source industrial and operational technology software, where AI agents can now rapidly analyze unfamiliar codebases that previously relied on obscurity for protection. For Linux distributions and scientific computing facilities running EPICS, the 7.0.11 update is critical, as these controllers bridge operators to physical equipment where exploitation can cause real-world damage, experiment destruction, or infrastructure shutdown. The demonstration also raises urgent questions about defensive applications of similar AI capabilities, as the same techniques could be weaponized against critical infrastructure before patches deploy.
What to do
- Users of EPICS Base should update to version 7.0.11 or later to fix the vulnerabilities
- Administrators of affected systems should watch for signs of exploitation, including denial of service, memory corruption, information disclosure, or arbitrary code execution
- Facilities using EPICS to control physical equipment, such as particle accelerators and fusion reactors, should prioritize this update
Original reference: www.theregister.com →